ascii image


0010101000011111101001101010000010011000
1110101110110101011011111010010010001011
0001011100011101111001010011010010111110
0000010111101001100000110011101100001000
0011000000111010001111111000100110000001
1010110110000000000001011001000110001010
0101100010101100000100000010100100010101
0001011001011101100011000101110111101110
0110010100110100111101110100110011111101
0010111100110011010010110010101111011011
0100000000001001001011000010110100101001
1101000111100000110111011100110111000010
1111110001111111101101001010000111101100
0010110000100000111011000000101100010110
0101111000011100111010000000011111101111
0010010011110010011101001000110101000101
0000000001000100001111111100111010001111

Saturday, 22 February 2014

Lenovo z710 and Ubuntu 13.10 wifi auto connect fix

My z710 wasn't auto connecting the wifi at bootup.

rfkill list showed odd modules that were blocked but not shown loaded with lsmod.

root@nick-Lenovo-Z710:~# rfkill list
0: ideapad_wlan: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: ideapad_3g: Wireless WAN
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
4: brcmwl-0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no


Feb 22 20:24:25 nick-Lenovo-Z710 NetworkManager[942]: <info> rfkill0: found WiFi radio killswitch (at /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:02/PNP0C09:00/VPC2004:00/rfkill/rfkill0) (platform driver ideapad_acpi)
Feb 22 20:24:25 nick-Lenovo-Z710 NetworkManager[942]: <info> rfkill2: found WWAN radio killswitch (at /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:02/PNP0C09:00/VPC2004:00/rfkill/rfkill2) (platform driver ideapad_acpi)
Feb 22 20:24:25 nick-Lenovo-Z710 NetworkManager[942]: <info> rfkill3: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ieee80211/phy0/rfkill3) (driver wl)
Feb 22 20:24:25 nick-Lenovo-Z710 NetworkManager[942]: <info> rfkill4: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0/net/eth1/rfkill4) (driver wl)
Feb 22 20:24:25 nick-Lenovo-Z710 NetworkManager[942]: <info> WiFi enabled by radio killswitch; disabled by state file
Feb 22 20:24:25 nick-Lenovo-Z710 NetworkManager[942]: <info> WWAN enabled by radio killswitch; enabled by state file
Feb 22 20:24:25 nick-Lenovo-Z710 NetworkManager[942]: <info> WiMAX enabled by radio killswitch; enabled by state file
Feb 22 20:24:25 nick-Lenovo-Z710 NetworkManager[942]: <info> WiFi now disabled by radio killswitch



The easiest fix was to unload and reload the 'wl' module

rmmod wl
modprobe wl

so i put this into /etc/rc.local, rebooted.

Wifi auto connect worked as soon as i logged in.


No comments:

Post a comment